架設 WordPress出現 Cannot modify header information的解決方法

很多人在架設WordPress時,常常換用新佈景或是一開始安裝時常常會碰到一個錯誤訊息
「Cannot modify header information – headers already sent by」
通常遇到問題別擔心,Google一下會有很多答案的,這問題其實發生再轉向時,緩衝區出了些問題,只要開啟一下系統設定調整一下,就可以解決這個問題了。

通常會出現在網頁轉向時,採用「header」函式,才造成這個緩衝區的錯誤訊息。

Cannot modify header information的解決方法


這個問題全句警告訊息是:

Warning: Cannot modify header information – headers already sent by

其實解決方法很簡單,只要調整一下php.ini內的設定值就可以正常了,換句話說,就是系統本身有個設定值預設是未開啟,只要我們將他開啟就可以了。

attachments/201402/8538586659.jpg

所以找到系統設定檔「php.ini」,建議使用「EMEdit文字編輯軟體」開啟,找到「output_buffering」並將他後面的值設定為「On」(啟動),當然也可以設定成「4096」或更高的數值(設定緩衝區大小),然後儲存並重新啟動Apache就可以了。

評論: 0 | 引用: 0 | 閱讀: 728