English Sentence Loading...
英語句子加載中...

【技術公告】osCommerce 的每一個版本的 install 目錄,安裝是不能通用的!

【技術公告】osCommerce 的每一個版本的 install 目錄,安裝是不能通用的!

訪客來信問道:
總教頭您好,我安裝新版的 osCommerce 2.3.4 出現以下警告:
FATAL ERROR: register_globals is disabled in php.ini, please enable it!
請問大師我該如何處理?

總教頭的回覆:
osCommerce 使用舊版2.2的 install 才會有此問題:
FATAL ERROR: register_globals is disabled in php.ini, please enable it!
安裝新版,請您千萬不要因此去照著舊版的教法,修改 php.ini的 register_globals
來符合安裝的要求,因為這種作法是天大的錯誤!!

-------------------------------------------------------
總教頭來解釋一下:
請注意!osCommerce 的每一個版本的 install 是不能通用的!
因為裡頭有MySQL檔案要寫入資料庫!每個版本的資料庫有時並不完全100%相同...
既然是新版,有時會加入或修正資料庫資料表中的某些部分...
那問題就發生了!

例如:有些笨蛋(天兵),因為最新版osCommerce的官方沒有中文化版
版本太新了!網路也找不到中文的 install 繁體中文安裝介面
官方是英文安裝版面......(資料庫沒有文化,有中文語系,後台還是會有某些選項是:英文!)
就下載網路先前 osCommerce的2.3.3 的中文版來更換與安裝
嘿嘿!當然可以安裝成功,可是日後不是這裡出現警告...
就是那裡功能不正常!
沒人知道原因所在?當然網路也找不到解決之道......連官方都不知道此事的始末與源由...
因為誰會知道竟然有此:天兵?(自作聰明)呢!
您還在找完整的osCommerce最新繁體中文化版嗎?
提示:只要您是總教頭的學生都歡迎來信索取最新版繁體中文化程式與技術服務
因為,中文化是需要花費時間與技術去處理的工程
我們專業免費技術服務:購物網站教學課程之學員!!
-----------------------------------------------

引用通告位址: http://por.tw/sale/trackback.php?tbID=361&extra=1ffcac
標籤: 技術諮詢與回覆
評論: 0 | 引用: 0 | 閱讀: 287
 加入網摘